Bill2's Process Manager : le forum

Bill2's Process Manager, Votre gestionnaire de processus automatique
 
AccueilAccueil  FAQFAQ  RechercherRechercher  S'enregistrerS'enregistrer  MembresMembres  GroupesGroupes  Connexion  

Partagez | 
 

 Exception de priorité automatique non appliquée

Voir le sujet précédent Voir le sujet suivant Aller en bas 
AuteurMessage
Yanos
Beta testeur officiel
Beta testeur officiel
avatar

Nombre de messages : 28
Age : 43
Date d'inscription : 26/01/2007

MessageSujet: Exception de priorité automatique non appliquée   Mar 27 Nov - 7:43

Salut mon Billou,

Bon j'ai un souci, il le fallait depuis le temps que tout ce passait bien Wink

J'utilise un programme de modélisation de BDD franco-français "Win'Design". Et ce dernier lorsqu'il génère mes scripts SQL travaille dur (projet de plus de 300 tables).

Le problème c'est que PM lui coupe la chique malgré le fait d'avoir ajouté ce programme dans les exceptions. J'ai essayé avec et sans le chemin complet, rien n'y fait Sad

Dossier d'install :
C:\Program Files\win'design\win'design 7.0\PROGRAMMES

Nom de l'exe :
WinDsign.exe

Voili, voilou,

A++

Yanos
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Bill2
Administrateur
Administrateur
avatar

Nombre de messages : 418
Age : 39
Localisation : Dijon
Date d'inscription : 21/11/2006

MessageSujet: Re: Exception de priorité automatique non appliquée   Mar 27 Nov - 18:15

Ah, un rapport de bug de mon petit yanos Smile

Alors là, c'est strange quand même.
Chez moi, la fonction marche impec.
Faudra que je vérifie si ça ne vient pas du chemin qui comporte un ', mais je ne pense pas.

Au pire, je te ferais un petit exe "spécial" avec des commandes de débug pour "voir" ce qu'il y a en mémoire Wink

Tu es bien avec la v3.0 ?
Et si tu coupes la fonction de prio auto, c'est OK ?

_________________
Rubik's Addicted !
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://www.bill2-software.com/processmanager
Yanos
Beta testeur officiel
Beta testeur officiel
avatar

Nombre de messages : 28
Age : 43
Date d'inscription : 26/01/2007

MessageSujet: Re: Exception de priorité automatique non appliquée   Mar 27 Nov - 18:30

Ha nan j'ai pas testé sans la priorité auto, je vérifie ca demain car c'est sur mon poste du boulot.

A++

Yanos
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Yanos
Beta testeur officiel
Beta testeur officiel
avatar

Nombre de messages : 28
Age : 43
Date d'inscription : 26/01/2007

MessageSujet: Re: Exception de priorité automatique non appliquée   Mer 28 Nov - 7:14

Salut,

Bon bin je dois avoir l'ordi de Mulder & Scully, car ce matin tout fonctionne nickel Razz

A++

Yanos
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Bill2
Administrateur
Administrateur
avatar

Nombre de messages : 418
Age : 39
Localisation : Dijon
Date d'inscription : 21/11/2006

MessageSujet: Re: Exception de priorité automatique non appliquée   Mer 28 Nov - 13:06

Ah. Trop fort.
Parce que bon, j'ai retesté vite fait...
j'ai mis un prog en exception, je l'ai fait tourner à 100% : ok.
Je l'ai suppr des exceptions, et hop, 10s plus tard, il passait en idle.
Bon, j'ai pas encore poussé les tests en mettant un' dans le path, mais je vais le faire.

Sinon, ben, ça veut tout simplement dire qu'il y eu un "bug" lors de l'init, et que le process a été "mal" enregistré en mémoire par PM.

Donc, au cas ou, je vais revérifier le code exécuté lors de l'instanciation Neutral

_________________
Rubik's Addicted !
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://www.bill2-software.com/processmanager
Yanos
Beta testeur officiel
Beta testeur officiel
avatar

Nombre de messages : 28
Age : 43
Date d'inscription : 26/01/2007

MessageSujet: Re: Exception de priorité automatique non appliquée   Mer 28 Nov - 13:14

Mouaip je ne sais pas trop qu'elle peut être la blague confused

Mais je surveille ca !

A++

Yanos
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Bill2
Administrateur
Administrateur
avatar

Nombre de messages : 418
Age : 39
Localisation : Dijon
Date d'inscription : 21/11/2006

MessageSujet: Re: Exception de priorité automatique non appliquée   Mer 28 Nov - 17:33

Au pire, si ça recommence, il faudra stopper PM et le relancer, voir si là c'est OK.

Si oui, ça voudra dire qu'il y a parfois certains soft qui sont mal détectés ... mais je ne vois pas pourquoi ...

_________________
Rubik's Addicted !
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://www.bill2-software.com/processmanager
Yanos
Beta testeur officiel
Beta testeur officiel
avatar

Nombre de messages : 28
Age : 43
Date d'inscription : 26/01/2007

MessageSujet: J'ai des news ;)   Jeu 29 Nov - 9:11

Salut,

Bon alors le problème se répète a priori à chaque redémarrage de mon poste. Et il n'y a pas que Win'Design qui à le problème, mais également "Server SQL Management Studio Express". Donc je ne pense pas que se soit du à l'apostrophe dans le chemin de Win'Design.

Donc ce que j'ai fait ce matin :
- rebelotte Win'Design est bridé, je vais dans les options, je désactive la priorité automatiqu, j'applique, je réactive l'option, j'applique. Tout refonctionne nickel.
- je ferme ma session de travail, PM n'est plus en mémoire, j'ouvre ma session de travail pas de souci.
- je redémarre mon poste complètement, plonk, Win'Design est bridé.
- je regarde mes programmes dans les exceptions et je teste "Server SQL Management Studio Express", plonk bridé.
- je vais dans les options pour refaire ma manip du début. Win'Design n'est plus bridé, mais SSMSE toujours.
- je quitte PM, le relance, plus de problème null part.

La différence entre les deux c'est que Win'Design est enregistré avec son nom uniquement alors que SSMSE est enregistré avec son chemin complet. Je ne sais pas si ca t'aide.

A savoir que PM est en exécution automatique à l'ouverture de ma session, et que j'ai plusieurs services qui se lancent au démarrage, ce qui peut peut-être expliqué que ca n'arrive qu'au redémarrage et pas à l'ouverture de ma session les services étant déjà lancés.

Pour info ce poste est un : Intel Core DUO - 4400 @ 2.00GHz

Voila,

A++

Yanos
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Bill2
Administrateur
Administrateur
avatar

Nombre de messages : 418
Age : 39
Localisation : Dijon
Date d'inscription : 21/11/2006

MessageSujet: Re: Exception de priorité automatique non appliquée   Jeu 29 Nov - 9:30

Euh, je récap pour voir si j'ai tout bien compris

- lorsque PM démarrage avec l'ordi, la liste des exceptions ne fonctionne pas.
- Lorsque tu stoppes puis relance PM "manuellement", là c'est OK

Et c'est valable pour le "*\prog.exe" ET le "chemin complet\prog.exe" ?

Bon, faut que je regarde ça de plus près là, ça me semble strange tout de même !
Tu pourrais m'envoyer le config.xml, que je vérifie la liste des exceptions, au cas où ?

_________________
Rubik's Addicted !
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://www.bill2-software.com/processmanager
Yanos
Beta testeur officiel
Beta testeur officiel
avatar

Nombre de messages : 28
Age : 43
Date d'inscription : 26/01/2007

MessageSujet: Re: Exception de priorité automatique non appliquée   Jeu 29 Nov - 9:44

T'as tout compris Wink

Je précise que la désactivation/réactivation de la priorité auto a l'air de corriger le problème pour *\prog.exe uniquement.

Je t'envoi mon fichier de config de suite.

A++

Yanos
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Yanos
Beta testeur officiel
Beta testeur officiel
avatar

Nombre de messages : 28
Age : 43
Date d'inscription : 26/01/2007

MessageSujet: Re: Exception de priorité automatique non appliquée   Ven 30 Nov - 6:51

Salut,

Petit débreifing du matin Wink

Alors je confirme qu'au redémarrage mes applis ne sont pas détectées par la priorité automatique. Je suis aller dans les options, désactivé/réactivé la priorité auto sans avoir fermées mes applis, toujours pas détectées. Je ferme les applis et les réouvre, détectées, toutes les deux.

Voila,

A bientot pour de nouvelles aventures Wink

A++

Yanos
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Yanos
Beta testeur officiel
Beta testeur officiel
avatar

Nombre de messages : 28
Age : 43
Date d'inscription : 26/01/2007

MessageSujet: Re: Exception de priorité automatique non appliquée   Lun 3 Déc - 7:11

Salut,

Bon alors je ne pense pas que se soit du à un problème de redémarrage réellement, mais plutot un problème du à un temps de chargement des applications assez long. Ce qui a lieu à chaque redémarrage, la mémoire étant vide. Le système utilise un cache pour les DLL et les EXE ce qui fait qu'une fois qu'une appli est lancée elle s'ouvre largement plus rapidement que la première fois.

C'est un constat que j'ai fait en voyant le log de ce matin, j'ai lancé une première fois SSMSE, pas détecté comme d'hab et une erreur dans le log, je ferme et réouvre pas de problème tout est OK. Et plus tard je constate que j'ai l'erreur pour firefox, skype, msn, outlook. Bref des applis qui sont un peu longuette à charger la première fois.

Je pense que le temps que certaines choses soit en mémoire il doit y avoir un verrou mémoire, ce qui provoque ton erreur.

Pour pallier à cela, plutot que de mettre des timers, se serait peut-être de faire une sorte de décompte, je m'explique : plutot que de récupérer les informations à chaque fois que tu détecte un nouveau processus, se serait de mettre en mémoire une information genre à 5. A chaque rafraichissement tu recherches les processus dont le compteur est >0, si tu récupères les infos sans problème alors tu place le compteur à 0, sinon tu le décrémente. Ainsi au prochain rafraichissement tu recommencera tes vérifications pour les process qui sont encore en cours de chargement. Au bout d'un certains temps (après 5 vérifications) on peut considérer que ce processus est protégé en mémoire et donc certaines infos ne sont pas disponibles. Ca peut-être un décompte ou une vérification dans le temps (au bout de X secondes).

A++

Yanos
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Bill2
Administrateur
Administrateur
avatar

Nombre de messages : 418
Age : 39
Localisation : Dijon
Date d'inscription : 21/11/2006

MessageSujet: Re: Exception de priorité automatique non appliquée   Lun 3 Déc - 7:27

Hello !

Bon, ben, de bon matin, ça fait des news sympas Smile
Tu pourras me renvoyer les logs tout de même, j'y jetterais un oeil.

Sinon, effectivement, je penche moi aussi du côté d'un pb lors du premier chargement en mémoire.

J'ai déjà rencontré le bug avec certains softs, mais pas de façon systématique. (donc pas facile à débugguer !)

Je vais réfléchir à ta proposition pour solutionner le truc.

Ce qui me chiffonne, c'est que sur mon poste au taf, PM démarre avec le système, et je n'ai jamais eu aucun pb avec Outlook.

Je pense qu'à l'init de process, je vais vérifier la date de lancement du process et comparer aec le time en cours, et si la différence est trop petite, j'estimerai que le process n'est pas encore complètement lancé, et donc je ne le mémoriserai pas de suite.
Enfin, ce n'est qu'une idée hein ...

Au fait, tu as eu mon message sur ton MSN, avec la vérif que je te proposais de faire ?

Tu peux me mailer direct sur l'adresse de ProcessManager, je suis pas au taf aujourd'hui Wink

_________________
Rubik's Addicted !
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://www.bill2-software.com/processmanager
Contenu sponsorisé




MessageSujet: Re: Exception de priorité automatique non appliquée   

Revenir en haut Aller en bas
 
Exception de priorité automatique non appliquée
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 1
 Sujets similaires
-
» L'agriculture doit être une des priorités des efforts de la reconstruction
» Énième recensement des armes d'exception.
» Mirlande Manigat dévoile ses priorités
» Fruit du Démon et Sabres d'exception oubliés ?
» résu automatique dans une arène

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
Bill2's Process Manager : le forum :: Bugs-
Sauter vers: