Bill2's Process Manager : le forum

Bill2's Process Manager, Votre gestionnaire de processus automatique
 
AccueilAccueil  FAQFAQ  RechercherRechercher  S'enregistrerS'enregistrer  MembresMembres  GroupesGroupes  Connexion  

Partagez | 
 

 [Résolu] Plantage de BPM dès son lancement, sans rapport de crash..

Voir le sujet précédent Voir le sujet suivant Aller en bas 
AuteurMessage
Johan_et_Pirlouit

avatar

Nombre de messages : 7
Date d'inscription : 28/07/2010

MessageSujet: [Résolu] Plantage de BPM dès son lancement, sans rapport de crash..   Mer 28 Juil - 7:21

Bonjour à tous,

Tout d'abord un grand merci à Bill2 pour ce délicieux programme Wink ...

Aujourd'hui, j'avoue être surpris par son plantage : dès le lancement de BPM j'ai droit à la fenêtre Windows "Bill2's Process Manager executable a cessé de fonctionner".

Ma config :
- AMD Phenom II X2 555 (Virtualisation AMD-V activée)
- Chipset AMD 785G (ATI HD 4200 intégré)
- Windows 7 Pro édition 64 bits
- BPM 3.4.3.1

Ce problème est survenu après que j'ai effectué un lot de mises à jour :
- Catalyst 10.7 suite complète (pilotes graphiques, chipset, etc.)
- Realtek HD Audio Codec
- Realtek Gigabit Ethernet

Le seul rapport de crash que j'ai est celui généré par l'observateur d'évènements de Windows. Voici son contenu :

Code:
Version=1
EventType=CLR20r3
EventTime=129247735564045550
ReportType=2
Consent=1
ReportIdentifier=b3fbb66e-9a14-11df-a0bb-6cf049010ba2
Response.type=4
Sig[0].Name=Signature du problème 01
Sig[0].Value=processmanager.exe
Sig[1].Name=Signature du problème 02
Sig[1].Value=3.4.3.1
Sig[2].Name=Signature du problème 03
Sig[2].Value=4bffcbaa
Sig[3].Name=Signature du problème 04
Sig[3].Value=ProcessManager
Sig[4].Name=Signature du problème 05
Sig[4].Value=3.4.3.1
Sig[5].Name=Signature du problème 06
Sig[5].Value=4bffcbaa
Sig[6].Name=Signature du problème 07
Sig[6].Value=25
Sig[7].Name=Signature du problème 08
Sig[7].Value=e0
Sig[8].Name=Signature du problème 09
Sig[8].Value=System.InvalidOperationException
DynamicSig[1].Name=Version du système
DynamicSig[1].Value=6.1.7600.2.0.0.256.48
DynamicSig[2].Name=Identificateur de paramètres régionaux
DynamicSig[2].Value=1036
UI[2]=C:\Program Files (x86)\Bill2's Process Manager\ProcessManager.exe
UI[3]=Bill2's Process Manager executable a cessé de fonctionner
UI[4]=Windows peut rechercher une solution au problème en ligne.
UI[5]=Rechercher une solution en ligne et fermer le programme
UI[6]=Rechercher ultérieurement une solution en ligne et fermer le programme
UI[7]=Fermer le programme
LoadedModule[0]=C:\Program Files (x86)\Bill2's Process Manager\ProcessManager.exe
LoadedModule[1]=C:\Windows\SYSTEM32\ntdll.dll
LoadedModule[2]=C:\Windows\SYSTEM32\MSCOREE.DLL
LoadedModule[3]=C:\Windows\system32\KERNEL32.dll
LoadedModule[4]=C:\Windows\system32\KERNELBASE.dll
LoadedModule[5]=C:\Windows\system32\ADVAPI32.dll
LoadedModule[6]=C:\Windows\system32\msvcrt.dll
LoadedModule[7]=C:\Windows\SYSTEM32\sechost.dll
LoadedModule[8]=C:\Windows\system32\RPCRT4.dll
LoadedModule[9]=C:\Windows\Microsoft.NET\Framework64\v4.0.30319\mscoreei.dll
LoadedModule[10]=C:\Windows\system32\SHLWAPI.dll
LoadedModule[11]=C:\Windows\system32\GDI32.dll
LoadedModule[12]=C:\Windows\system32\USER32.dll
LoadedModule[13]=C:\Windows\system32\LPK.dll
LoadedModule[14]=C:\Windows\system32\USP10.dll
LoadedModule[15]=C:\Windows\system32\IMM32.DLL
LoadedModule[16]=C:\Windows\system32\MSCTF.dll
LoadedModule[17]=C:\Windows\Microsoft.NET\Framework64\v2.0.50727\mscorwks.dll
LoadedModule[18]=C:\Windows\WinSxS\amd64_microsoft.vc80.crt_1fc8b3b9a1e18e3b_8.0.50727.4927_none_88dce9872fb18caf\MSVCR80.dll
LoadedModule[19]=C:\Windows\system32\shell32.dll
LoadedModule[20]=C:\Windows\system32\ole32.dll
LoadedModule[21]=C:\Windows\system32\profapi.dll
LoadedModule[22]=C:\Windows\assembly\NativeImages_v2.0.50727_64\mscorlib\9a017aa8d51322f18a40f414fa35872d\mscorlib.ni.dll
LoadedModule[23]=C:\Windows\system32\CRYPTBASE.dll
LoadedModule[24]=C:\Windows\system32\uxtheme.dll
LoadedModule[25]=C:\Windows\assembly\NativeImages_v2.0.50727_64\System\247913fa7ae6fcf04ea33d28d24ab611\System.ni.dll
LoadedModule[26]=C:\Windows\assembly\NativeImages_v2.0.50727_64\Microsoft.VisualBas#\1ec65ef1b8265780b3a6e7f1855db885\Microsoft.VisualBasic.ni.dll
LoadedModule[27]=C:\Windows\Microsoft.NET\Framework64\v2.0.50727\mscorjit.dll
LoadedModule[28]=C:\Windows\assembly\NativeImages_v2.0.50727_64\System.Drawing\10f1e1ffca16e550af8a8fd7685a48ef\System.Drawing.ni.dll
LoadedModule[29]=C:\Windows\assembly\NativeImages_v2.0.50727_64\System.Windows.Forms\4ef67456cbb05e89bd81169d602b415b\System.Windows.Forms.ni.dll
LoadedModule[30]=C:\Windows\system32\dwmapi.dll
LoadedModule[31]=C:\Windows\assembly\NativeImages_v2.0.50727_64\System.Runtime.Remo#\28b3698c0e8eac7c31e65542ece11346\System.Runtime.Remoting.ni.dll
LoadedModule[32]=C:\Windows\system32\shfolder.dll
LoadedModule[33]=C:\Windows\WinSxS\amd64_microsoft.windows.gdiplus_6595b64144ccf1df_1.1.7600.16385_none_2b4f45e87195fcc4\gdiplus.dll
LoadedModule[34]=C:\Windows\system32\CRYPTSP.dll
LoadedModule[35]=C:\Windows\system32\rsaenh.dll
LoadedModule[36]=C:\Windows\system32\RpcRtRemote.dll
LoadedModule[37]=C:\Program Files (x86)\Bill2's Process Manager\fr-FR\ProcessManager.resources.dll
LoadedModule[38]=C:\Windows\system32\version.dll
LoadedModule[39]=C:\Windows\assembly\NativeImages_v2.0.50727_64\System.Xml\1fb1b14199d6aec70df1a0626a3ae5f2\System.Xml.ni.dll
LoadedModule[40]=C:\Windows\assembly\NativeImages_v2.0.50727_64\System.Configuration\ae96fb17747476cb8f791ab8131ce537\System.Configuration.ni.dll
LoadedModule[41]=C:\Windows\assembly\GAC_MSIL\System.Xml.resources\2.0.0.0_fr_b77a5c561934e089\System.Xml.resources.dll
LoadedModule[42]=C:\Windows\assembly\GAC_MSIL\System.Configuration.resources\2.0.0.0_fr_b03f5f7f11d50a3a\System.Configuration.resources.dll
LoadedModule[43]=C:\Windows\assembly\GAC_MSIL\mscorlib.resources\2.0.0.0_fr_b77a5c561934e089\mscorlib.resources.dll
LoadedModule[44]=C:\Windows\assembly\GAC_MSIL\Microsoft.VisualBasic.resources\8.0.0.0_fr_b03f5f7f11d50a3a\Microsoft.VisualBasic.resources.dll
LoadedModule[45]=C:\Windows\assembly\NativeImages_v2.0.50727_64\System.Management\c58314beec308d002d31dd33ff970d5e\System.Management.ni.dll
LoadedModule[46]=C:\Windows\system32\apphelp.dll
FriendlyEventName=Fonctionnement arrêté
ConsentKey=CLR20r3
AppName=Bill2's Process Manager executable
AppPath=C:\Program Files (x86)\Bill2's Process Manager\ProcessManager.exe
ReportDescription=Stopped working

J'ai eu beau désinstaller complètement BPM, le ré-installer, essayer la procédure de soucis de droits décrite dans la FAQ, essayer les modes de compatibilités pour ProcessManager.exe, rien n'y fait et je sèche fortement scratch ! Idem en désactivant la virtualisation dans le Bios ou en vérifiant la présence du .Net requis.

Si vous avez des idées (service en particulier à démarrer, dépendance à satisfaire, autre), je suis preneur... Je me doute qu'il s'agit peut-être de quelque chose de très simple, mais pour le moment je ne trouve pas.

Salutations,
Johan


Dernière édition par Johan_et_Pirlouit le Lun 2 Aoû - 0:43, édité 1 fois
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Bill2
Administrateur
Administrateur
avatar

Nombre de messages : 418
Age : 39
Localisation : Dijon
Date d'inscription : 21/11/2006

MessageSujet: Re: [Résolu] Plantage de BPM dès son lancement, sans rapport de crash..   Mer 28 Juil - 8:43

Bonjour, et merci à vous pour ce rapport très détaillé.

A tout hasard, vous pouvez aller dans le répertoire de BPM et/ou dans le répertoire de config, pour vérifier si il n'existe pas un fichier de crash, mais je ne pense pas.
L'appli est détectée comme défaillante par Windows avant même de générer un crash.

Il faudrait tester d'autres programmes en .Net, voir si ils sont aussi touchés. Par exemple : Paint.net (quoi que ... il n'utilise pas la même version du framework ...)

Si d'autres programmes en .net ne fonctionnent plus, alors le soucis ne viendrait pas de BPM.

Dans un premier temps, seule chose à faire : tenter de réinstaller le framework .net 2.0 "seul", et voir ce que ça donne. Ensuite, appliquer les dernières MAJ du framework.
Sinon, pour le moment, je ne vois pas trop que faire d'autre. Sad


Autre piste : tenter une réparation par SFC-Scannow =>
http://forums.cnetfrance.fr/topic/243-sfc-scannow-verifier-les-fichiers-systemes/

_________________
Rubik's Addicted !
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://www.bill2-software.com/processmanager
Johan_et_Pirlouit

avatar

Nombre de messages : 7
Date d'inscription : 28/07/2010

MessageSujet: Re: [Résolu] Plantage de BPM dès son lancement, sans rapport de crash..   Sam 31 Juil - 3:19

Bonjour Bill2,

Après quelques essais, voici qui ne va pas nous avancer beaucoup...

1. Un sfc /scannow a retourné qu'aucun fichier n'était altéré.

2. Un checkup basique des .NET framworks installés (.NET Framework Setup Verification Tool) a conclu que tout était normal et fonctionnel.


Mon OS étant Windows 7, le .NET Framework 3.5 est inclus dedans, donc aussi le 2.0 et le 3.0. Du coup :

3. Une purge des installations de .NET Framwork (.NET Framework Cleanup Tool) n'a fait que supprimer la dernière supprimable : .NET 4.0 Client (je n'ai pas la 1.1 d'installée, elle n'est d'ailleurs probablement pas installable sur Win7, voire inutile).


Sur Windows 7, impossible de ré-installer le .NET Framework 2.0 : l'installeur renvoie "Vous devez utiliser l'option Activer ou désactiver des fonctionnalités Windows du Panneau de Configuration blablabla". Idem pour les 3.0 / 3.5.

Impossible de faire autrement qu'en exécutant une réparation de Windows via le DVD d'install (ma sauvegarde système était un peu dépassée et je n'avais pas pensé à en faire une au moment de la mise à jour de la Catalyst Suite 10.4 vers la 10.7).

Donc, j'ai fait ceci :

4. Un chkdsk C: /r depuis la console de récupération du DVD d'install de Win7 : pas d'erreurs (parenthèse : le disque système n'était d'ailleurs pas mappé en C: à ce moment là, ce sont les bizarreries de l'attribution des lettres par l'installeur de Win7 pour sa console de récupération).

5. Une réparation de Windows par le même DVD d'install (procédure d'effectuer une mise à niveau) : ça a remis les modules de Windows 7 "par défaut" (obligeant à repasser par la case Windows Update) : .NET remis en version 3.5."0". Sans résultat pour BPM.

6. Passage par le Windows Update qui, de fait, a installé la mise à jour .NET Framework 3.5.1 : toujours aucun résultat pour BPM.


BPM ne démarre toujours pas, le rapport de plantage de Windows reste strictement identique à celui que j'ai déposé dans mon premier post...


Côté rapport de crash de BPM, à moins de n'avoir pas regardé au bon endroit, je ne vois aucun fichier qui y ressemble :
- Dans "C:\Users\moi\AppData\Local\Bill2_Software\ProcessManager.exe_Url_p0kbfql433s5xo24fwyy4nx42fys5qjr\3.4.3.1" -> je n'ai que user.config.
- Dans "C:\Users\moi\AppData\Local\Bill2's Process Manager" aucun fichier.
- Et dans "C:\Program Files (x86)\Bill2's Process Manager" et ses sous-dossiers, rien d'autre le le prog et ses fichiers annexes (langues, icônes, etc.).

Donc, par ici rien de nouveau, peut-être qu'une future version de BPM aidera Crying or Very sad ... A moins qu'un autre visiteur du forum ait pu investiguer mieux que moi sur un problème similaire.

Johan
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Bill2
Administrateur
Administrateur
avatar

Nombre de messages : 418
Age : 39
Localisation : Dijon
Date d'inscription : 21/11/2006

MessageSujet: Re: [Résolu] Plantage de BPM dès son lancement, sans rapport de crash..   Sam 31 Juil - 6:08

Merci pour tout ces diagnostics.

Avez-vous tenté d'utiliser une autre programme utilisant le framework .net 2.0 ?

Parce que si un tel programme plante aussi, alors le soucis viendra bien du framework.
Sinon, c'est que BPM sera en cause ... mais pourquoi, pour le moment, je n'en sais rien Sad

Edit : j'ai fait quelques recherche en plus sur le net.
Au final, à moins d'être sur la machine pour debugguer, ça risque d'être compliqué.
Néamoins, il reste une piste à explorer : Sauvegardez le fichier config.xml (par exemple en le renommant).
Si il existe un fichier update.xml, faites pareil.
Ensuite, tentez de lancer le programme.
Si ça fonctionne, alors c'est que le fichier de conf est corrompu, dans ce cas, il faudra m'envoyer la sauvegarde, que je regarde ce qui provoque cette erreur.

Si ça plante toujours, il faudra tenter la même manip avec le fichier "user.config" que vous avez localisé (en supprimant carrément le dossier qui le contient, après l'avoir sauvegardé ça ira très bien !)

Merci encore pour tous ces tests. Je tente de faire de mon mieux de mon côté pour élucider ce mystère.
Si jamais la suppression des différents fichier résout le soucis, il faudra vraiment me les envoyer pour que j'analyse et corrige ce problème que je n'avais encore jamais rencontré.
Si le prog refonctionne, vous trouverez mon e-mail dans la boite "a propos", et/ou sur mon site web Smile

_________________
Rubik's Addicted !
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://www.bill2-software.com/processmanager
Johan_et_Pirlouit

avatar

Nombre de messages : 7
Date d'inscription : 28/07/2010

MessageSujet: Bonne nouvelle !!   Lun 2 Aoû - 0:33

Bill2 a écrit:
Avez-vous tenté d'utiliser une autre programme utilisant le framework .net 2.0 ?
C'est ce que j'avais oublié de préciser dans mon précédent post : parmi ma collec' de freewares, je n'en ai pas retrouvé qui utilisent le .NET 2.0.

Bill2 a écrit:
Néamoins, il reste une piste à explorer : Sauvegardez le fichier config.xml (par exemple en le renommant).
Si il existe un fichier update.xml, faites pareil.
Ensuite, tentez de lancer le programme.
Si ça fonctionne, alors c'est que le fichier de conf est corrompu, dans ce cas, il faudra m'envoyer la sauvegarde, que je regarde ce qui provoque cette erreur.

Si ça plante toujours, il faudra tenter la même manip avec le fichier "user.config" que vous avez localisé (en supprimant carrément le dossier qui le contient, après l'avoir sauvegardé ça ira très bien !)
Pourquoi donc n'ai-je pas pensé à vérifier que la désinstallation de BPM avait bien vidé ses dossiers ? Un excès de confiance, peut-être. Mais c'est vrai que le processus de mise à jour de BPM conserve, lui, les fichiers de config...

Peu importe, le problème est résolu : c'était bien "user.config" qui était "mort". Sa suppression a résolu le problème, BPM est reparti au 1/4 de poil Very Happy !

Comme vous l'avez demandé, je vous ai envoyé par mail la copie du "user.config" réduit en bouillie.

Sincères salutations,
Johan
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Bill2
Administrateur
Administrateur
avatar

Nombre de messages : 418
Age : 39
Localisation : Dijon
Date d'inscription : 21/11/2006

MessageSujet: Re: [Résolu] Plantage de BPM dès son lancement, sans rapport de crash..   Lun 2 Aoû - 5:46

Cool Smile

Et bien, je vais regarder tout ça de très près !
Je vous tiendrai au courant quoi qu'il en soit.

Si j'arrive à "corriger" le soucis, ça sera intégré dans la prochaine MAJ.

Merci encore à vous pour tous les tests réalisés.

_________________
Rubik's Addicted !
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://www.bill2-software.com/processmanager
Bill2
Administrateur
Administrateur
avatar

Nombre de messages : 418
Age : 39
Localisation : Dijon
Date d'inscription : 21/11/2006

MessageSujet: Re: [Résolu] Plantage de BPM dès son lancement, sans rapport de crash..   Ven 6 Aoû - 7:32

Bon, bonne nouvelle, grace à ce fichier, j'ai pu reproduire facilement le bug.

Pour la solution, j'ai dû me trouver un joli bout de code sur le Web, histoire de m'éviter de chercher pendant des heures.

Au final, ça me semble correct : plus de crash lorsque le fichier user.config est corrompu Smile

Je compte publier la mise à jour d'ici peu de temps.
Merci encore à vous pour le rapport de crash, et les tests réalisés.

_________________
Rubik's Addicted !
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://www.bill2-software.com/processmanager
Johan_et_Pirlouit

avatar

Nombre de messages : 7
Date d'inscription : 28/07/2010

MessageSujet: Re: [Résolu] Plantage de BPM dès son lancement, sans rapport de crash..   Dim 8 Aoû - 15:04

Un morceau de souvenir me revient : il me semble que la corruption de user.config s'est produite suite à un redémarrage de Windows qui ne s'est pas terminé après mes mises à niveau de pilotes : si je me souviens, c'est le moteur de ZoneAlarm Free (la dernière version en date à ce jour : 9.1.007.004) qui a eu du mal à démarrer et qui a provoqué un plantage de Windows au moment où, apparemment, BPM démarrait. Voili pour la fin du "rapport", qui arrive un poil en retard Embarassed ...


Sinon, c'est toujours un plaisir d'aider, dans la mesure de ce que je peux faire, des développeurs qui nous mettent à disposition gratuitement leurs travaux, surtout si ces travaux sont des incontournables et qu'ils sont voués à rester gratuits Wink ...

Bonne continuation,
Johan
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Bill2
Administrateur
Administrateur
avatar

Nombre de messages : 418
Age : 39
Localisation : Dijon
Date d'inscription : 21/11/2006

MessageSujet: Re: [Résolu] Plantage de BPM dès son lancement, sans rapport de crash..   Lun 9 Aoû - 14:53

Ah ça, les MAJ systèmes, des fois, ça fout le bazar !

Bon, la nouvelle version est arrivée Smile
Normalement, meme en reprennant le fichier corrompu, ça ne doit plus planter Very Happy

_________________
Rubik's Addicted !
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://www.bill2-software.com/processmanager
Johan_et_Pirlouit

avatar

Nombre de messages : 7
Date d'inscription : 28/07/2010

MessageSujet: Re: [Résolu] Plantage de BPM dès son lancement, sans rapport de crash..   Lun 9 Aoû - 23:17

Et hop, mise à jour installée...

Merci Wink


EDIT : petit test pour la forme avec le vieux fichier corrompu et aucun soucis de démarrage...
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Bill2
Administrateur
Administrateur
avatar

Nombre de messages : 418
Age : 39
Localisation : Dijon
Date d'inscription : 21/11/2006

MessageSujet: Re: [Résolu] Plantage de BPM dès son lancement, sans rapport de crash..   Mar 10 Aoû - 4:33

Hello,

Ca, au moins, c'est du retour d'information bien suivi, c'est super !
Merci pour la confirmation !

_________________
Rubik's Addicted !
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://www.bill2-software.com/processmanager
Contenu sponsorisé




MessageSujet: Re: [Résolu] Plantage de BPM dès son lancement, sans rapport de crash..   

Revenir en haut Aller en bas
 
[Résolu] Plantage de BPM dès son lancement, sans rapport de crash..
Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 1
 Sujets similaires
-
» Un truc sans rapport avec OGame
» USAID ap envesti nan planing familyal ann AYITI
» Le palais Sans-souci en Danger
» Il n'y pas de vie sans agriculture...
» Land des Gabions, un modèle de site pour les sans-abri

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
Bill2's Process Manager : le forum :: Bugs-
Sauter vers: